XThreads
Author Message
My Spiel
XThreads is one of my larger plugins which I have been working on for a while.  Originally planned to release it inline with MyBB 1.6, but who knows when that'll be out.  It perhaps doesn't include everything I wanted it to, but does have most of the things (plus I want to move onto other projects).

What does it do?
Take a look at RateU's forum for some nice ideas of what it can do.  I also have some more basic examples here of what can be done with XThreads.  I'm pretty sure there are many other applications of this plugin, but those examples just give you some simple ideas.

The basic idea is giving you the ability to define custom fields for your threads, and providing methods to give you a lot of flexibility with customising forums.

Warning: I'm not going to bother with "beta" labels and so on.  I've done some testing on this myself, but it's by no means extensive.  Use this at your own risk.

Installation Instructions: standard installation procedures apply - you can find them in the announcement here.
You may need to CHMOD the uploads/xthreads_ul/ folder to 0777 after uploading the files (probably won't though).

Upgrade Instructions: unless stated otherwise, the general procedure for upgrades is to simply upload the new files, then visit your AdminCP.  In there, you'll be presented with a notice to run the upgrade - just follow what it says from there on.

Usage Instructions: this is a complex plugin, and unfortunately, you're probably going to have to figure this out yourself, depending on what you want to achieve with this plugin.  HTML and CSS knowledge is strongly recommended; you should also be familiar with MyBB's template system.  Some demonstrations can be found here - hopefully these will give you a good idea of how things work.  I suggest looking at the thread descriptions example, as this is fairly easy to understand (IMO).  If you can understand how everything works, there, perhaps try out the gallery example.

Known conflicting plugins
- MyPlaza Turbo -
If you are using MyPlaza Turbo, note that the author decided to use a particularly odd method to implement certain functionality, practically destroying compatibility with any plugin which hooks into the forum add/edit routines.  I've included a patch to address this issue - you need to replace inc/myplaza/myplaza_admin_plugin.php with the following file (it's unlikely that this will be committed as the author has decided to discontinue development)

.php  myplaza_admin_plugin.php (Size: 56.27 KB / Downloads: 1238)

- PL9 Forum Icons -
Affects certain functionality.  See here for a solution.

- PHP in Templates, v1.4 or older -
Similar to PL9 Forum Icons - solution is just to update to the latest version.

- MyAdvertisements - (update: older versions only, later versions may not conflict)
Affects some thread functionality, see here for a solution.

- Group Post CSS -
See here http://mybbhacks.zingaburga.com/showthre...17#pid5917

All bug reports, suggestions, criticisms are appreciated (though I may not always implement suggestions) so please feel free to post them.
If you find this plugin useful, I would be grateful if you could give some token of appreciation for the work that has gone into this, and perhaps post some example usages you've come up with in the XThreads forum to help others get an idea of what can be achieve with this plugin (and for my own interest's sake Tongue).


Github: https://github.com/zingaburga/XThreads-MyBB-Plugin
Note: do NOT use the Github version, unless you know what you're doing
Changelogs: v1.10, v1.20, v1.21, v1.22, v1.23, v1.24, v1.25, v1.26, v1.27, v1.30, v1.31, v1.32, v1.337, v1.40, v1.41, v1.42, v1.43, v1.44, v1.45, v1.46, v1.47, v1.50, v1.51, v1.52, v1.53, v1.60, v1.61, v1.62, v1.63, v1.64, v1.65, v1.66, v1.67, v1.68
(This post was last modified: 12-25-2015 12:46 PM by ZiNgA BuRgA.)
Find all posts by this user
Quote this message in a reply
Download: xthreads-1.68.7z (114.53 KB)
Plugin Version: 1.68
Last Updated: 12-25-2015, 12:46 PM

Downloads: 6,852
MyBB Compatibility: 1.4.x, 1.6.x, 1.8.x
Plugin License: GPLv3
Uploader: ZiNgA BuRgA
FullMetalBabe Offline
Junior Member
**
Posts: 5
Joined: Jun 2012
Post: #631
RE: XThreads
(11-27-2012 11:00 AM)ZiNgA BuRgA Wrote:  Thanks for testing.

(11-27-2012 09:21 AM)FullMetalBabe Wrote:  http://i.minus.com/iN0P4V5dJhcOl.jpg is one of the pics I tried with.
Grr, cURL (and fopen wrapper for that matter) doesn't properly do redirects (and they don't mention it in their documentation).
If you use the correct URL, http://i5.minus.com/iN0P4V5dJhcOl.jpg it should work, but I'll need to look at seeing if I can fix up the automatic redirect detection.

That's no problem, I am pretty sure I'd be the only one using minus.com as my users don't know of it.

(11-27-2012 11:00 AM)ZiNgA BuRgA Wrote:  
(11-27-2012 09:21 AM)FullMetalBabe Wrote:  edit: Also without JS I don't get the endless loading circle when I post from quick reply.
Are you sure this is an issue with XThreads?

To disable the JS I deleted the xthread JS file from my server to test it a bit better (I couldn't find an option to disable JS on my browser) once I disabled the xthread JS (xthread_attach_input) the quick reply worked perfectly.

(11-27-2012 11:00 AM)ZiNgA BuRgA Wrote:  
(11-27-2012 09:21 AM)FullMetalBabe Wrote:  Edit #2: Forgot to mention, lol. The upload worked on Firefox (computer upload) with the JS active, but I got a endless loading when I used quick reply. I used Chrome originally, though. Nothing worked there with JS active.
Chrome broke something in their newer versions it seems.  I tested with an older version and it seemed to work fine...

Chrome seems to be a devil lately... a huge PIA. I'll alert my users about chrome to fix it for now, although I personally gave up hope on it. The only pesky thing is the endless loading image with every other browser. ;~;

(11-27-2012 11:00 AM)ZiNgA BuRgA Wrote:  
(11-27-2012 09:21 AM)FullMetalBabe Wrote:  When I used a photobucket image link it worked but only showed the Photobucket image - not the one uploaded from my computer.
That's odd though.  If you enter both an URL and a file, it always prefers the file.  Works as intended in Chrome from the test I just performed.
Chrome's issue is that it requires a valid URL to be entered, even if there's no URL field (since you chose to upload a file rather than URL fetch), and thus falls on itself when you try to click a submit button.  So you should be able to upload a file if you fill the URL field in with something that's a valid URL.

I did, I uploaded the file and a photobucket image, it still chose to upload the photobucket image.
11-27-2012 12:08 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #632
RE: XThreads
(11-27-2012 12:08 PM)FullMetalBabe Wrote:  To disable the JS I deleted the xthread JS file from my server to test it a bit better (I couldn't find an option to disable JS on my browser) once I disabled the xthread JS (xthread_attach_input) the quick reply worked perfectly.
Doesn't really disable JS (inline scripts still execute), but it's still odd as xthreads_attach_input.js shouldn't even load on showthread pages (does it on yours?).

(11-27-2012 12:08 PM)FullMetalBabe Wrote:  Chrome seems to be a devil lately... a huge PIA. I'll alert my users about chrome to fix it for now, although I personally gave up hope on it. The only pesky thing is the endless loading image with every other browser. ;~;
Fix is rather easy.  I guess I should've thought it may happen, but it just didn't on the browsers I tested.
To fix, open up inc/xthreads/xt_admin.php, find type="url" and replace with type="text"
After you do that, edit any thread field (just select one then submit - this forces the cache to be rebuilt).

(11-27-2012 12:08 PM)FullMetalBabe Wrote:  I did, I uploaded the file and a photobucket image, it still chose to upload the photobucket image.
Would you be able to try the same thing here?  If so, and you've managed to replicate the behaviour, post up the URL and image you used?
Thanks.

My Blog
11-27-2012 01:23 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #633
RE: XThreads
Updated to v1.62:
  • fix Chrome not submitting posts with a file field (thanks to FullMetalBabe for pointing out)
  • fix redirect handling for URL fetching in cURL and fopen handlers (thanks to FullMetalBabe for pointing out)

My Blog
11-28-2012 03:26 PM
Find all posts by this user Quote this message in a reply
leefish Offline
Hamster
*******
Posts: 1,009
Joined: Apr 2010
Post: #634
RE: XThreads
Thanks for the fix ZB. Now I think about it, I was forced to use Chrome instead of Opera when I was testing while my ISP were being rotters. maybe this was my issue after all. Frown


[Image: leelink.gif]
MYBB1.6 & XThreads
12-01-2012 10:01 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Glas Offline
Member
***
Posts: 106
Joined: Jul 2010
Post: #635
RE: XThreads
¿Is it safe to update to new version?

It may cause some data/setup loss of custom thread fields/values?
12-04-2012 01:19 AM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #636
RE: XThreads
(12-04-2012 01:19 AM)Glas Wrote:  ¿Is it safe to update to new version?

It may cause some data/setup loss of custom thread fields/values?
Of course not.  I posted it so that it could delete everything in your forum to see if anyone would fall for it.

My Blog
12-04-2012 06:59 AM
Find all posts by this user Quote this message in a reply
Glas Offline
Member
***
Posts: 106
Joined: Jul 2010
Post: #637
RE: XThreads
(12-04-2012 06:59 AM)ZiNgA BuRgA Wrote:  
(12-04-2012 01:19 AM)Glas Wrote:  ¿Is it safe to update to new version?

It may cause some data/setup loss of custom thread fields/values?
Of course not.  I posted it so that it could delete everything in your forum to see if anyone would fall for it.

Nice irony, although i was talking serious, i remember some patches ago i've updated and some config got resetted, had to input values manually again

and as i saw a hotfix for xthreads recently (if i recall correctly) i was a bit worried

sorry for asking though =/
12-04-2012 10:40 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #638
RE: XThreads
(12-04-2012 10:40 PM)Glas Wrote:  although i was talking serious
Seems like you should've thought seriously before talking serious.

(12-04-2012 10:40 PM)Glas Wrote:  i remember some patches ago i've updated and some config got resetted, had to input values manually again
I doubt you had to, but anyway...

My Blog
12-05-2012 09:29 AM
Find all posts by this user Quote this message in a reply
RateU Offline
Administrator
*******
Posts: 2,325
Joined: Mar 2010
Post: #639
RE: XThreads
Ugh... I'm three version behind...
Thank you very much for the update, Yumi!
Many new features added Smile

12-06-2012 04:49 AM
Find all posts by this user Quote this message in a reply
Glas Offline
Member
***
Posts: 106
Joined: Jul 2010
Post: #640
RE: XThreads
Upgraded
so far so good

Thanks Zinga
12-07-2012 01:13 AM
Find all posts by this user Quote this message in a reply


Forum Jump: