Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 link directory...can someone make this?
Shemo Offline
Member
***
Posts: 184
Joined: Jan 2008
Post: #31
RE: link directory...can someone make this?
(08-05-2010 07:29 AM)RateU Wrote:  Please remember that sometimes the thumbnail service need a "time" to "capture" your link for the first time, if the link isn't cached yet by them. So, sometimes you need to wait for 10 - 15 seconds and refresh the page to receive the thumbnail. This only happens for the first time you submit the link and the link isn't cached yet by them.

very nice..you should add this to your main tutorial, too

another working demo:
http://www.pazrt.com/forum/forum-ammunition-stores
08-05-2010 02:04 PM
Find all posts by this user Quote this message in a reply
Firefox Wins Offline
Member
***
Posts: 164
Joined: Mar 2008
Post: #32
RE: link directory...can someone make this?
@RateU
Your efforts are inspiring; I need to take the time to learn to use XThreads, and you are making it much easier.
Thanks Smile
08-05-2010 04:31 PM
Find all posts by this user Quote this message in a reply
RateU Offline
Administrator
*******
Posts: 2,349
Joined: Mar 2010
Post: #33
RE: link directory...can someone make this?
(08-05-2010 02:04 PM)Shemo Wrote:  you should add this to your main tutorial, too

I've updated it. Thanks Smile

1. Edit xtld_forumdisplay_thread. Now we have auto link thumbnail, submitted by and date / time submitted. Suggested by RocketFoot and Shemo. Thanks Smile
2. Added xtld_forumdisplay_sticky_sep and xtld_forumdisplay_threads_sep template.
3. Place the {$attacherror} back to xtld_newthread template, just in case if we want to use an attachment. thanks to leefish Smile


(08-05-2010 04:31 PM)Firefox Wins Wrote:  @RateU
Your efforts are inspiring; I need to take the time to learn to use XThreads, and you are making it much easier.
Thanks Smile

That only this I can do to express my gratitude to Yumi. My efforts is nothing compared with the efforts he had done to code XThreads - the amazing tools - for us. Unfortunately, I'm not a coder nor a template designer, so, I can't create many interesting application with it.

08-08-2010 07:22 AM
Find all posts by this user Quote this message in a reply
RocketFoot Offline
Senior Member
****
Posts: 338
Joined: Jul 2010
Post: #34
RE: link directory...can someone make this?
I've finally had the time to add this to my forum.  Everything seems to be working except when I add a link, it auto redirects to the new link when you submit the thread and the back button doesn't seem to work either.  I must have done something wrong but I can't find where I messed up!

http://www.7173mustangs.com/forum-link-directory

Login:
mybbtester1
tester

Is there a way to redirect back to the link index instead of going to the website when creating a new thread and also, why doesn't my back button work?  At the least, is there a way to make the new link post open in a new page?

Thanks guys!
(This post was last modified: 10-13-2010 01:25 AM by RocketFoot.)
10-12-2010 09:55 PM
Find all posts by this user Quote this message in a reply
RateU Offline
Administrator
*******
Posts: 2,349
Joined: Mar 2010
Post: #35
RE: link directory...can someone make this?
I'm really sorry for my late answer, Rocketfoot. I'm not in the fit condition in this week Biggrin

For the newthread link:
Create a new template in global template:
xtld_forumdisplay_newthread

HTML Code
<a href="newthread.php?fid={$fid}" target="_blank"><img src="{$theme['imglangdir']}/newthread.gif" alt="{$lang->post_thread}" title="{$lang->post_thread}" /></a>

You can change the newthread button image there, if you have a button for the newlink. Something like this:

HTML Code
<a href="newthread.php?fid={$fid}" target="_blank"><img src="{$theme['imglangdir']}/newlink.png" alt="Submit A New Link" title="Submit A new Link" /></a>


For the Back "button", I've updated it for additional link (edit post link) in threadlist, and I've updated the Redirect Time Delay:
Required at least XThreads v 1.32:

  1. Edit Redirect Delay custom thread fields:
    Blank Replacement Value: and Display Format: (to keep the "compatibility" for existing thread):

    Code:
    <if $mybb->user['usergroup'] == 4 then>21<else>2</if>

  2. Edit Back custom thread fields:
    Blank Replacement Value: and Display Format: (to keep the "compatibility" for existing thread):

    HTML Code
    1
    2
    3
    4
    5
    6
    <if THIS_SCRIPT == 'forumdisplay.php' && $mybb->user['usergroup'] == 4 then>
    	<span> - <strong><a href="{$mybb->settings['bburl']}/editpost.php?pid={$thread['firstpost']}">Edit</a></strong></span>
    </if>
    <if THIS_SCRIPT == 'showthread.php' && $mybb->user['usergroup'] == 4 then>
    	<div style="text-align: center;"><strong><a href="{$forumurl}">Back</a></strong></div>
    </if>

  3. Then, edit xtld_forumdisplay_thread template, add {$GLOBALS['threadfields']['xtldback']} to the template, something like this:

    HTML Code
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    <tr>
    	<td align="center" class="{$bgcolor}" width="1">
    		<a href="{$thread['threadlink']}" target="_blank"><img src="http://www.iwebtool2.com/img/?r={$mybb->settings['bburl']}/&amp;domain={$GLOBALS['threadfields']['xtldwww']}" alt="{$thread['subject']}" title="{$thread['subject']}" style="width: 120px; height: 90px;" /></a>
    	</td>
    	<td class="{$bgcolor}">
    		<strong><a href="{$thread['threadlink']}" target="_blank" class="{$inline_edit_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a></strong>
    		({$thread['views']} {$lang->views}){$GLOBALS['threadfields']['xtldback']}
    		<div class="smalltext"><strong>Submitted By: {$thread['profilelink']}</strong> - <em>{$thread['threaddate']} at {$thread['threadtime']}</em></div>
    		<div class="smalltext">{$GLOBALS['threadfields']['xtlddesc']}</div>
    	</td>
    	{$modbit}
    </tr>

    This update will add edit post link for each thread in thread list (viewable for admin only). So, when we need to edit a thread, we don't need to view the postbit, just click the edit link Biggrin
    Links In Categories - Admin View:
       

    Links In Categories - User View:
       



For the redirecting to the Link Directory Index after submitting a new link, we need a plugin for that. I've attached the example plugin.
Open up the file, edit this line:

PHP Code:
array(21,22,23,24)

List your forum id for each link directory there. In that sample, there are 21,22,23 and 24. Then, upload it to your inc/plugins directory. Activate it.

Again, I'm really sorry for this late.



Attached File(s)
.php  xtlinkdirectory.php (Size: 914 bytes / Downloads: 314)

10-13-2010 06:24 AM
Find all posts by this user Quote this message in a reply
RocketFoot Offline
Senior Member
****
Posts: 338
Joined: Jul 2010
Post: #36
RE: link directory...can someone make this?
RateU, you do not need to apologize!  I am just glad you have the patience to help me!

Thank you very much!  I think these changes are exactley what I needed!  Edits done and testing now...

Biggrin
Thank you again!
(This post was last modified: 10-13-2010 08:10 AM by RocketFoot.)
10-13-2010 08:10 AM
Find all posts by this user Quote this message in a reply
leefish Offline
Hamster
*******
Posts: 1,009
Joined: Apr 2010
Post: #37
RE: link directory...can someone make this?
Hi there RateU - an odd thing is happening - I cannot edit any of the links threads once they are submitted. When I edit all goes well until I hit update link - then it says the message is missing, please enter a message.

I checked that I had set the forum to accept threads with no messages and the settings are correct. This was happening BEFORE I added the new changes -  so I am stumped. I am on 1.6, but I think thats not the issue. Can you help?


[Image: leelink.gif]
MYBB1.6 & XThreads
10-13-2010 10:09 AM
Visit this user's website Find all posts by this user Quote this message in a reply
RocketFoot Offline
Senior Member
****
Posts: 338
Joined: Jul 2010
Post: #38
RE: link directory...can someone make this?
Seems to be working OK for me...I am on the latest X-Threads version though.
10-13-2010 11:38 PM
Find all posts by this user Quote this message in a reply
leefish Offline
Hamster
*******
Posts: 1,009
Joined: Apr 2010
Post: #39
RE: link directory...can someone make this?
(10-13-2010 11:38 PM)RocketFoot Wrote:  Seems to be working OK for me...I am on the latest X-Threads version though.

Hi Rocketfoot - so am I - no tight pants here Wink - but are you on 1.6?


[Image: leelink.gif]
MYBB1.6 & XThreads
10-14-2010 12:14 AM
Visit this user's website Find all posts by this user Quote this message in a reply
RateU Offline
Administrator
*******
Posts: 2,349
Joined: Mar 2010
Post: #40
RE: link directory...can someone make this?
For 1.6:
Try to add this code after {$extra_threadfields}{$posticons} variables in xtld_editpost template (around line #38):

HTML Code
1
2
3
4
5
6
7
8
<tr style="display: none;">
	<td class="trow2" valign="top">
		<strong>{$lang->your_message}:</strong>
	</td>
	<td class="trow2">
		<textarea name="message" id="message" rows="20" cols="70" tabindex="3">{$message}</textarea>
	</td>
</tr>


10-14-2010 05:02 AM
Find all posts by this user Quote this message in a reply

« Next Oldest | Next Newest »

 Standard Tools
Forum Jump: