XThreads
Author Message
My Spiel
XThreads is one of my larger plugins which I have been working on for a while.  Originally planned to release it inline with MyBB 1.6, but who knows when that'll be out.  It perhaps doesn't include everything I wanted it to, but does have most of the things (plus I want to move onto other projects).

What does it do?
Take a look at RateU's forum for some nice ideas of what it can do.  I also have some more basic examples here of what can be done with XThreads.  I'm pretty sure there are many other applications of this plugin, but those examples just give you some simple ideas.

The basic idea is giving you the ability to define custom fields for your threads, and providing methods to give you a lot of flexibility with customising forums.

Warning: I'm not going to bother with "beta" labels and so on.  I've done some testing on this myself, but it's by no means extensive.  Use this at your own risk.

Installation Instructions: standard installation procedures apply - you can find them in the announcement here.
You may need to CHMOD the uploads/xthreads_ul/ folder to 0777 after uploading the files (probably won't though).

Upgrade Instructions: unless stated otherwise, the general procedure for upgrades is to simply upload the new files, then visit your AdminCP.  In there, you'll be presented with a notice to run the upgrade - just follow what it says from there on.

Usage Instructions: this is a complex plugin, and unfortunately, you're probably going to have to figure this out yourself, depending on what you want to achieve with this plugin.  HTML and CSS knowledge is strongly recommended; you should also be familiar with MyBB's template system.  Some demonstrations can be found here - hopefully these will give you a good idea of how things work.  I suggest looking at the thread descriptions example, as this is fairly easy to understand (IMO).  If you can understand how everything works, there, perhaps try out the gallery example.

Known conflicting plugins
- MyPlaza Turbo -
If you are using MyPlaza Turbo, note that the author decided to use a particularly odd method to implement certain functionality, practically destroying compatibility with any plugin which hooks into the forum add/edit routines.  I've included a patch to address this issue - you need to replace inc/myplaza/myplaza_admin_plugin.php with the following file (it's unlikely that this will be committed as the author has decided to discontinue development)

.php  myplaza_admin_plugin.php (Size: 56.27 KB / Downloads: 1252)

- PL9 Forum Icons -
Affects certain functionality.  See here for a solution.

- PHP in Templates, v1.4 or older -
Similar to PL9 Forum Icons - solution is just to update to the latest version.

- MyAdvertisements - (update: older versions only, later versions may not conflict)
Affects some thread functionality, see here for a solution.

- Group Post CSS -
See here http://mybbhacks.zingaburga.com/showthre...17#pid5917

All bug reports, suggestions, criticisms are appreciated (though I may not always implement suggestions) so please feel free to post them.
If you find this plugin useful, I would be grateful if you could give some token of appreciation for the work that has gone into this, and perhaps post some example usages you've come up with in the XThreads forum to help others get an idea of what can be achieve with this plugin (and for my own interest's sake Tongue).


Github: https://github.com/zingaburga/XThreads-MyBB-Plugin
Note: do NOT use the Github version, unless you know what you're doing
Changelogs: v1.10, v1.20, v1.21, v1.22, v1.23, v1.24, v1.25, v1.26, v1.27, v1.30, v1.31, v1.32, v1.337, v1.40, v1.41, v1.42, v1.43, v1.44, v1.45, v1.46, v1.47, v1.50, v1.51, v1.52, v1.53, v1.60, v1.61, v1.62, v1.63, v1.64, v1.65, v1.66, v1.67, v1.68
(This post was last modified: 12-25-2015 12:46 PM by ZiNgA BuRgA.)
Find all posts by this user
Quote this message in a reply
Download: xthreads-1.68.7z (114.53 KB)
Plugin Version: 1.68
Last Updated: 12-25-2015, 12:46 PM

Downloads: 6,907
MyBB Compatibility: 1.4.x, 1.6.x, 1.8.x
Plugin License: GPLv3
Uploader: ZiNgA BuRgA
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #21
RE: XThreads
Thanks for the comments Smile

My Blog
05-27-2010 08:32 AM
Find all posts by this user Quote this message in a reply
zehel Offline
Junior Member
**
Posts: 1
Joined: Jun 2010
Post: #22
RE: XThreads
Hey Yumi, thank you for this incredible plugin.
I wanted to tell you that you're the best plugin creator mybb has ever known IMO.
Thanks for all the hard work. Wink
06-04-2010 07:17 AM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #23
RE: XThreads
Thanks for the comments zehel (I probably wouldn't quite put myself there though Tongue)

My Blog
06-04-2010 08:43 AM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #24
RE: XThreads
Hello yumi, you thread plugin is mind blowing..

But in the recent version I thing there is a bug.

When a we post and comment in  xthread forum where first post is on, the comments also uses the postbit_first instead of using postbit template..
06-06-2010 11:47 AM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #25
RE: XThreads
(06-06-2010 11:47 AM)sept Wrote:  Hello yumi, you thread plugin is mind blowing..

But in the recent version I thing there is a bug.

When a we post and comment in  xthread forum where first post is on, the comments also uses the postbit_first instead of using postbit template..
Hi sept, could you please elaborate on what you're exactly doing?

I just tried here and it appears to work as expected - that is, it doesn't use the postbit_first template.

Perhaps set up a clean MyBB install, install XThreads and tell me step-by-step how to reproduce the issue.
Thanks!

My Blog
06-06-2010 12:18 PM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #26
RE: XThreads
It does not occur on old version of xthread only in the latest one.....
It happened while I was trying to modify a forum to this http://mybbhacks.zingaburga.com/showthread.php?tid=305

Anyways I will test it again and inform you....


EDIT:

I have tested it in a new installation but problem still exist....

More over there is another thing if I put a code like
Quote:<tr><td class="thead"><strong>Categories</strong></td></tr>
<tr><td class="trow1"><a href="{$forumurl?}filtertf_atcgal=Music"><span><strong>Music</strong></span></a></td></tr>
<tr><td class="trow1"><a href="{$forumurl?}filtertf_atcgal=Games"><span><strong>Games</strong></span></a></td></tr>
<tr><td class="trow1"><a href="{$forumurl?}filtertf_atcgal=Other"><span><strong>Other</strong></span></a></td></tr>
in key_forumdisplay_threadlist(code is from http://mybbhacks.zingaburga.com/showthread.php?tid=301 example) template I get blank thread list blank, refer to the screenshot:
   

but if i remove that code from the template the thread list shows up:

   

I am not sure that is this a problem with the plugin or the example code..
Previously I used the example with a previous version of xthread and it worked there, but it is not working in 1.1.7
(This post was last modified: 06-06-2010 04:00 PM by sept.)
06-06-2010 02:22 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #27
RE: XThreads
I'll have a look at the first thing.
As for the second thing, you can't use {$forumurl?} in templates unfortunately.  Replace it with forumdisplay.php?fid={$fid}&amp;

Thanks.

My Blog
(This post was last modified: 06-06-2010 04:10 PM by ZiNgA BuRgA.)
06-06-2010 04:05 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #28
RE: XThreads
(06-06-2010 02:22 PM)sept Wrote:  It does not occur on old version of xthread only in the latest one.....
It happened while I was trying to modify a forum to this http://mybbhacks.zingaburga.com/showthread.php?tid=305
I tried that and did everything to the letter, but unfortunately, posting replies seems to work fine here.

This is what I did:
  1. Install MyBB 1.4.13 on localhost
  2. Install & activate XThreads 1.10
  3. Make a new forum for the product review
  4. Do everything that guide says
  5. Visit the forum and make a new thread
  6. On the showthread page, post a reply - works with the AJAX quick reply
  7. Also test the normal (non-AJAX / quick) reply - also seems to work.


Have you done something a bit different?
Thanks Tongue

My Blog
06-06-2010 05:22 PM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #29
RE: XThreads
First of all thanks for the replies...
The second problem has been resolved...

No I have not changed anything...
(This post was last modified: 06-06-2010 07:04 PM by sept.)
06-06-2010 05:38 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #30
RE: XThreads
Weird.

Are you testing this under localhost?  Also, what PHP version are you running?

My Blog
06-06-2010 07:35 PM
Find all posts by this user Quote this message in a reply


Forum Jump: