XThreads
Author Message
My Spiel
XThreads is one of my larger plugins which I have been working on for a while.  Originally planned to release it inline with MyBB 1.6, but who knows when that'll be out.  It perhaps doesn't include everything I wanted it to, but does have most of the things (plus I want to move onto other projects).

What does it do?
Take a look at RateU's forum for some nice ideas of what it can do.  I also have some more basic examples here of what can be done with XThreads.  I'm pretty sure there are many other applications of this plugin, but those examples just give you some simple ideas.

The basic idea is giving you the ability to define custom fields for your threads, and providing methods to give you a lot of flexibility with customising forums.

Warning: I'm not going to bother with "beta" labels and so on.  I've done some testing on this myself, but it's by no means extensive.  Use this at your own risk.

Installation Instructions: standard installation procedures apply - you can find them in the announcement here.
You may need to CHMOD the uploads/xthreads_ul/ folder to 0777 after uploading the files (probably won't though).

Upgrade Instructions: unless stated otherwise, the general procedure for upgrades is to simply upload the new files, then visit your AdminCP.  In there, you'll be presented with a notice to run the upgrade - just follow what it says from there on.

Usage Instructions: this is a complex plugin, and unfortunately, you're probably going to have to figure this out yourself, depending on what you want to achieve with this plugin.  HTML and CSS knowledge is strongly recommended; you should also be familiar with MyBB's template system.  Some demonstrations can be found here - hopefully these will give you a good idea of how things work.  I suggest looking at the thread descriptions example, as this is fairly easy to understand (IMO).  If you can understand how everything works, there, perhaps try out the gallery example.

Known conflicting plugins
- MyPlaza Turbo -
If you are using MyPlaza Turbo, note that the author decided to use a particularly odd method to implement certain functionality, practically destroying compatibility with any plugin which hooks into the forum add/edit routines.  I've included a patch to address this issue - you need to replace inc/myplaza/myplaza_admin_plugin.php with the following file (it's unlikely that this will be committed as the author has decided to discontinue development)

.php  myplaza_admin_plugin.php (Size: 56.27 KB / Downloads: 1252)

- PL9 Forum Icons -
Affects certain functionality.  See here for a solution.

- PHP in Templates, v1.4 or older -
Similar to PL9 Forum Icons - solution is just to update to the latest version.

- MyAdvertisements - (update: older versions only, later versions may not conflict)
Affects some thread functionality, see here for a solution.

- Group Post CSS -
See here http://mybbhacks.zingaburga.com/showthre...17#pid5917

All bug reports, suggestions, criticisms are appreciated (though I may not always implement suggestions) so please feel free to post them.
If you find this plugin useful, I would be grateful if you could give some token of appreciation for the work that has gone into this, and perhaps post some example usages you've come up with in the XThreads forum to help others get an idea of what can be achieve with this plugin (and for my own interest's sake Tongue).


Github: https://github.com/zingaburga/XThreads-MyBB-Plugin
Note: do NOT use the Github version, unless you know what you're doing
Changelogs: v1.10, v1.20, v1.21, v1.22, v1.23, v1.24, v1.25, v1.26, v1.27, v1.30, v1.31, v1.32, v1.337, v1.40, v1.41, v1.42, v1.43, v1.44, v1.45, v1.46, v1.47, v1.50, v1.51, v1.52, v1.53, v1.60, v1.61, v1.62, v1.63, v1.64, v1.65, v1.66, v1.67, v1.68
(This post was last modified: 12-25-2015 12:46 PM by ZiNgA BuRgA.)
Find all posts by this user
Quote this message in a reply
Download: xthreads-1.68.7z (114.53 KB)
Plugin Version: 1.68
Last Updated: 12-25-2015, 12:46 PM

Downloads: 6,907
MyBB Compatibility: 1.4.x, 1.6.x, 1.8.x
Plugin License: GPLv3
Uploader: ZiNgA BuRgA
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #31
RE: XThreads
No I was testing on my host.....
On localhost the problem does not occur.......
I was using PHP version 5.2...


Some days ago I reinstalled mybb and imported the threads, post, users, etc table from the previous installation....
can this problem happen due to this????
06-06-2010 10:00 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #32
RE: XThreads
If you imported a database, you might want to double-check your templates, including those from all template sets.
Also, could possibly be a conflict with another plugin (could you list these?).
I can't really think of anything else unfortunately.

My Blog
(This post was last modified: 06-06-2010 10:07 PM by ZiNgA BuRgA.)
06-06-2010 10:04 PM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #33
RE: XThreads
I did not imported the whole database and I did not imported the template table.  

Plugins that I am using are:
Admins can log into Users' accounts (1.0)
Advanced Quick Reply Form
Akismet
Framed Avatar (Online,Ofline,Away) (3.0)
Color Notes (CSS extras) + bonus stuff (1.4)
Default Profile (2.1.0)
FancyZoom (1.2)
Fast way to change reputation (1.3.1)
Google Analytics (1.5)
Google SEO (1.1.13)
PL9 Forum Icons (1.1)
Private Messages Admin (2.4.1)
reCAPTCHA Plugin (1.3)
Trash Can Forum (2.0)
XThreads (1.10)
(This post was last modified: 06-06-2010 10:14 PM by sept.)
06-06-2010 10:14 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #34
RE: XThreads
That's a fair bit...  Are you able to try a clean install on localhost with XThreads with that product review forum, and add plugins one at a time to pinpoint which plugin is causing this?
Oh, also try it with the default theme on your host to see if it's a theme issue.

Thanks!

My Blog
(This post was last modified: 06-06-2010 10:29 PM by ZiNgA BuRgA.)
06-06-2010 10:28 PM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #35
RE: XThreads
I will try that...
06-06-2010 10:35 PM
Find all posts by this user Quote this message in a reply
RateU Offline
Administrator
*******
Posts: 2,327
Joined: Mar 2010
Post: #36
RE: XThreads
(06-06-2010 05:38 PM)sept Wrote:  The second problem has been resolved...

I'm really sorry for that problem, Sept Smile

For the Product Review Forum, I have a live demo for that. So, you can see it in a live forum:

http://mynie.6te.net/demo/showthread.php?tid=8

You can see the reply post doesn't use postbit_first template there.

06-07-2010 03:45 AM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #37
RE: XThreads
(06-06-2010 10:28 PM)ZiNgA BuRgA Wrote:  That's a fair bit...  Are you able to try a clean install on localhost with XThreads with that product review forum, and add plugins one at a time to pinpoint which plugin is causing this?
Oh, also try it with the default theme on your host to see if it's a theme issue.

Thanks!

OK I got the conflicting plugin, it is PL9 Forum Icons (1.1)...
So whats now??

it would be great if you help solving the problem..
Thanks...
(This post was last modified: 06-09-2010 11:40 PM by sept.)
06-09-2010 10:33 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #38
RE: XThreads
Wow, thanks for going to all that effort sept!
Interesting - though it doesn't seem like the plugin should be interfering.  I'll have to look into this tomorrow.

My Blog
06-09-2010 11:25 PM
Find all posts by this user Quote this message in a reply
ZiNgA BuRgA Offline
Fag
*******
Posts: 3,338
Joined: Jan 2008
Post: #39
RE: XThreads
Ahh, I see the reason.  It's because it's using an older version of my PHP in Templates plugin which has an issue with template cache modifications.

Use this instead:

.php  pl9forumicons.php (Size: 4.53 KB / Downloads: 350)

I've removed all the phptpl code, so you'll need to use this with the latest version of the PHP in Templates plugin:
http://mybbhacks.zingaburga.com/showthread.php?tid=260

Functionally, it'll be the same.

Hopefully that fixes it for you.
Thanks again for reporting the issue! (and going to all that effort) Smile

My Blog
06-10-2010 08:44 AM
Find all posts by this user Quote this message in a reply
sept Offline
Junior Member
**
Posts: 16
Joined: Jun 2010
Post: #40
RE: XThreads
Thanks, it is working now...........
(This post was last modified: 06-10-2010 11:36 AM by sept.)
06-10-2010 11:36 AM
Find all posts by this user Quote this message in a reply


Forum Jump: